Sum of even numbers
Write a program to find the sum of even numbers in an array.
Input Format:
Input consists of n+1 integers. The first integer corresponds to ‘n’ , the size of the array. The next ‘n’ integers correspond to the elements in the array. Assume that the maximum value of n is 15.
Output Format:
Refer sample output for details.
Sample Input :
5
2
3
6
8
-1
Sample Output 1:
The sum of the even numbers in the array is 16
Solution:
# include < stdio.h >
int main()
{
int n,a[20],i,sum=0;
scanf("%d",&n);
for(i=0;i < n;i++)
{
scanf("%d",&a[i]);
if(a[i]%2==0)
sum=sum+a[i];
}
printf("The sum of the even numbers in the array is %d",sum);
return 0;
}
No comments